Завершено

Mikrotik script generator V2.0

I am a co owner of a Wireless ISP.

I need a script generator to write two Mikrotik NAT rules in the following format for each set of customer data provided, and save the output as a .txt file, ready to be copied & pasted it into the router command line interface.

The 'srcnat and 'dstnat' scripts for each customer should be together, not all srcnat then all dstnats for example. I also need the option to be able to only have the SRCNAT rule, only the DSTnat rule, or both.

Example of output required for each set of customer data:

add action=netmap chain=srcnat comment="CustomerNumber" src-address= [login to view URL] to-addresses=[login to view URL]

add action=netmap chain=dstnat comment="CustomerNumber" dst-address= [login to view URL] to-addresses=[login to view URL]

The start of the whole script output should have "/ip firewall nat" ,(but not every srcnat & dstnat pair)

I would have a list of customer numbers, customer IP address and new static public IP There several hundred in total I would like to be able to enter from 1 set of data at least 100 sets at one time.

I would like to be able to paste these lists into a simple executable windows program and have it output in ascii text form a script ready to paste into the CLI interface of the mikrotik router. The rules should output in pair, (if the option for both dstnat and srcnat is selected)for example

"customername"

206-Fred Bloggs, Anytown [login to view URL] 520-Sean Smith, BallyDuff Woods [login to view URL] 223 - Pat Murphy, Kerry [login to view URL]

140-Mary Flaherty, Tralee [login to view URL]

658-Michael Kennedy - PortLaoise [login to view URL] 452 - Joan O'Mahony, Kilmacow [login to view URL] 759 - John & Maria Kelly, Dublin [login to view URL]

Public IP's

[login to view URL]

[login to view URL]

[login to view URL]

[login to view URL]

[login to view URL]

[login to view URL]

[login to view URL]

Квалификация: Администрирование сети, PHP, Shell Script, Архитектура ПО

Показать больше flash countdown script generator, script generator pedigree free, google maps api script generator marker, countdown script generator, website countdown script generator download myspace, googlemap script generator, code php script generator, script generator fonts, script generator banner php, auction script generator, premium script generator

О работодателе:
( 3 отзыв(-а, -ов) ) Waterford, Ireland

ID проекта: #19400194

Поручен:

emely001

Hi Andy, Between today and tomorrow I will have the application ready. Thanks for creating the project. Best regards.

€60 EUR за 2 дней(-я)
(4 отзывов(-а))
2.8

7 фрилансеров(-а) в среднем готовы выполнить эту работу за €156

shiningdevelopor

High-quality & Fast-delivery is promised! As a highly skilled full stack developer, I have rich experience in shell script. I am very confident with my skills and I'd like to help your business by doing my best. My Больше

€100 EUR за 3 дней(-я)
(83 отзывов(-а))
6.9
Zyrtec

Hi, I work as a network engineer in ISP company in Poland. We are using Mikrotik a lot. I am creating such scripts often for purpose of my work, and I will be happy to create one for you ;) in python - will be easy t Больше

€150 EUR за 10 дней(-я)
(4 отзывов(-а))
5.4
degabb

Good day! I can create script generator for RouterOS CLI confidently and quickly because I am a certified network engineer (MTCIPv6E/MTCTCE/MTCNA) having over 10 years of experience in configuring, maintaining and tro Больше

€222 EUR за 3 дней(-я)
(14 отзывов(-а))
4.8
alexeyilinsky

I can do this script for you with pleasure. Which programing language you prefer? I've strong experience with mikrtoik

€222 EUR за 1 день
(5 отзывов(-а))
3.6
santoshm143

Hi I am full time freelancer. I have strong communication skills and have flexible working hours. I assure you quality work ,complete attention and proper communication. I have more than 8 years of experience in Больше

€277 EUR за 3 дней(-я)
(5 отзывов(-а))
3.4
loftyara

Hi. I suggest you make a python script that takes in the command line some parameters and the name of the file with the source data and you get commands at the output. You can run it on any platform with python instal Больше

€60 EUR за 3 дней(-я)
(6 отзывов(-а))
3.3